Mabyduck - Crowdsourcing studies fail to launch – Incident details

All systems operational

Crowdsourcing studies fail to launch

Resolved
Partial outage
Started 7 days agoLasted 11 minutes

Affected

Crowdsourcing

Degraded performance from 8:14 AM to 8:15 AM, Operational from 8:15 AM to 8:25 AM

Updates
  • Resolved
    UTC
    Resolved
    This incident has been resolved.
  • Investigating
    UTC
    Investigating

    Our crowdsourcing provider is experiencing some issues. We've reached out and they are looking into it.